股票配资正规操作你的位置:国内允许股票配资_股票配资正规操作_安全股票配资申请 > 股票配资正规操作 > 20240125 通达信“龙头动能”副图指标选股公式--龙头狙击
20240125 通达信“龙头动能”副图指标选股公式--龙头狙击

发布日期:2024-02-04 05:19    点击次数:173

  

欧欧 欧欧量化 2024-01-25 08:01 发表于广西

图片

一、指标说明:二、副图公式如下:A0:=((L+H+C*2)/4);中:=EMA(A0,14)*1.0618,COLORWHITE,LINETHICK2;下:=EMA(A0,14),COLORRED,LINETHICK2;多空:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW,LINETHICK3;AA:=EMA((2*C+H+L)/4,3);A1:=SLOPE(AA*5-REF(AA,5),5)+C;DIF:=EMA(A1,3) - EMA(A1,13);DEA:=EMA(DIF,3);动能线:IF(C>中 AND C>下 AND C>多空 AND (DIF-DEA)>0,(DIF-DEA),0),COLORYELLOW;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线,2,0),COLORYELLOW;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.9,2,0),COLORYELLOW;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.8,2,0),COLORYELLOW;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.7,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线> 0),0,动能线*0.6,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.5,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.4,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.3,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.2,2,0),COLOR0000FF;STICKLINE(C>中 AND C>下 AND C>多空 AND (动能线 > 0),0,动能线*0.1,2,0),COLOR0000FF;龙:=CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));DRAWTEXT_FIX(C>O,0.01,0.1,0,'微信公众号:欧欧量化'),COLORRED;龙头阻击:(动能线>0 AND FILTER(龙,19));DRAWICON(龙头阻击,动能线*1.1,25);涨幅:=(C/REF(C,1)-1)*100;去ST:=NAMELIKE('ST')=0 AND NAMELIKE('*ST')=0 AND NAMELIKE('SST')=0 AND NAMELIKE('S*ST')=0;去除停牌:=DYNAINFO(4)>0;去除创业板:=IF(CODELIKE('300') OR CODELIKE('301') ,0,1) ;去除科创板:=IF(CODELIKE('688'),0,1);XG:=去ST AND 去除停牌 AND 去除科创板;MA10:=MA(CLOSE,10);MA54:=MA(CLOSE,54);CTA8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;CTA9:=FILTER(CTA8,10);CTA10:=BARSLAST(CTA9);CTA11:=REF(HIGH,CTA10+2);CTA12:=REF(HIGH,CTA10+1);CTA13:=REF(HIGH,CTA10);CTA14:=MAX(CTA11,CTA12);CTA15:=MAX(CTA14,CTA13);CTA16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>3.5;CTA17:=CTA10<150;CTA18:=(OPEN-CTA15)/CTA15*100<30;CTA19:=(CLOSE-LLV(LOW,CTA10))/LLV(LOW,CTA10)*100<50;CTA20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;CTA21:=VOL/MA(VOL,5)<3.5;CTA22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;CTA25:=CTA16 AND CTA17 AND CTA18 AND CTA19 AND CTA20 AND CTA21 AND CTA22;BOLL:=MA(CLOSE,20);UPPER:=BOLL+2*STD(CLOSE,20);PER:=CROSS(C,UPPER);CTB1:=MA((L+H+C)/3,5);CTB2:=HHV(CTB1,60);CTB3:=CROSS(C,CTB2*0.95) OR CROSS(C,CTB2*0.98) ;CTB4:=PER AND CTA25 AND CTB3;CTB5:=MA(CLOSE,25)+MA(CLOSE,25)*20/100*0.35;CTB6:=(MA(MA(H,25),25)-MA(MA(L,25),25))*1+MA(MA(H,25),25);CTB7:=REF(C<CTB6 OR C<CTB5,1) AND C>CTB6 AND C>CTB5 ;CTB8:=CTB4 OR CTB7;龙头趋势:动能线>0 AND ((涨幅>8 AND C=H) OR 涨幅>12)AND CTB8 AND XG AND C/REF(C,1)>1.05 AND REF(C,1)/REF(C,2)<1.04 AND REF(C>3.7,1) AND REF(C<19,1) AND (CAPITAL/100)/10000<=15 AND O/REF(C,1)<1.05 AND C>O,COLORRED;

三、龙头狙击选股公式:

A0:=((L+H+C*2)/4);

中:=EMA(A0,14)*1.0618,COLORWHITE,LINETHICK2;

下:=EMA(A0,14),COLORRED,LINETHICK2;

多空:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3);

AA:=EMA((2*C+H+L)/4,3);

A1:=SLOPE(AA*5-REF(AA,5),5)+C;

DIF:=EMA(A1,3) - EMA(A1,13);

DEA:=EMA(DIF,3);

动能线:=IF(C>中 AND C>下 AND C>多空 AND (DIF-DEA)>0,(DIF-DEA),0),;

龙:=CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));龙头阻击:(动能线>0 AND FILTER(龙,19));

风险提示:本指标公式仅作为知识分享,模拟测试不构成任何投资建议,不作投资依据。

图片

END 本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。